SharePoint 2010 Your Backup Is From A Different Version Of Microsoft SharePoint Foundation

Restoring a SharePoint site collection can be a pretty easy task.  If your interested in how to do that check this blog (Backup and Restore SharePoint 2010 Site Collection With PowerShell) where I explain the process. Unfortunately this is not always a foolproof process as I have recently found out.  Most errors are pretty self explanatory such as the site collection already exists, in which case change use the -Force command to overwrite it.

I recently came across the following error:


Restore-SPSite: Your backup is from a different version of Microsoft SharePoint Foundation and cannot be restored to a server running the current version. The backup file should be restored to a server with version ‘14.0.0.4762’ or later.

Imagine my surprise when I was trying to restore this to a newly installed SharePoint farm with all the updates applied. Below are the two reasons why you may get this error, in my case it was option number 2 that was causing the issue.

Cause 1:
The backup was in fact created from a later version of SharePoint.  You can check the current version through the Central Administration site.  Often times minor updates aren’t noticed in the user experience and go overlooked.  So be sure to check both locations and compare the version numbers even if you think that they are the same.  9 times out of 10 an admin has applied a patch that changes the version number on the source but not the destination.

Solution:
Either update the location where the restore is being done to the current version or get an earlier backup of the site collection when the versions were the same.  Unfortunately there isn’t really an easy solution if you don’t want to update the target location.

Cause 2:
The target system is in fact a later version of SharePoint than is listed in the error message.  This can be quite confusing since the restore should work given the information in the error message.  However, check to see if the target is running Service Pack 1 and the source is not. A pre-Service Pack 1 backup cannot be restored to a farm where Service Pack 1 is installed due to database schema changes. A better error message in that case would be lovely.

Solution:
Do the restore on a pre-SP1 install of SharePoint and then apply service pack 1.  Alternately, apply Service Pack 1 to a DEV server  where the site collection currently resides and take a backup.  Again, unfortunately neither solution is one that anyone wants to implement.

Bradley Schacht

Bradley Schacht is a Cloud Solution Architect on the state and local government team with Microsoft based in Jacksonville, FL. He has co-authored 3 SQL Server books including "SQL Server 2014 Professional Administration". As a former consultant and trainer, he uses his experience on many parts of the Microsoft BI and data platform to help customers deliver the best possible solutions. Bradley frequently presents at community events around the country. He is a contributor to sites such as SQLServerCentral.com and an active member of the Jacksonville SQL Server User Group (JSSUG).

You may also like...

Leave a Reply